Results 1 to 5 of 5

Thread: problem w/ ecu or injectors??

  1. #1

    Default problem w/ ecu or injectors??

    the car wont start with 650cc rc with crome ecu boosted program and tune for b16. now turbo runs just fine with prelude injectors and S200 tune and program for n/a. but i rather run it with the bigger injectors and and a boosted program.. which could be the faulty one
    Last edited by kaoxiong612; 11-24-2009 at 12:29 AM. Reason: forgot info

  2. #2
    Trained in the art of psi Krazed's Avatar
    Join Date
    Sep 2004
    Location
    My Boost technique is strong, you are no match!
    Posts
    10,922

    Default

    wow it sounds like you need to actually get it tuned and not run bs base maps

  3. #3

    Default

    Ya you will need to get a real tune for those injectors definitely.

  4. #4

    Default problem w/ ecu or injectors

    ID1000s would be the pick. They can be tuned to idle just as well as a 725.

    But in all fairness, I would of thought the RX8 440cc injectors were big enough for a Roxtrex setup...?

  5. #5

    Default -

    Ive recently installed a pro series ecu on my 07 rxt with the recommended 50lb injectors but its now over fueling and running rough at idle through to 4-5k? Im only running a et127 wheel so would chucking the 42s in be OK with out it leaning out at the top end?

    Any thoughts appreciated

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •