Results 1 to 12 of 12

Thread: 94' Accord turn signal not working

  1. #1

    Default 94' Accord turn signal not working

    I have this accord and the turn signals do not even turn on. So i tried the usual, changed out the flasher relay, checked the fuse, and pulled a blinker switch from the junkyard and tried that and nothing! Only thing that works is the hazzards. So at the switch I rigged a hotwire to the turn signal wire and is able to turn on as a temp fix. Can anyone help out here?

  2. #2

    Default

    As much as I know about Accords, this one stumps me. My friend is having the same trouble with his 96. I haven't been able to find an answer myself... Hopefully someone will be able to help!


    I love CBs. I really don't like CDs! (yes, I own cd5tuner.com... so sue me. )

    www.cb7tuner.com - 1990-1993 Honda Accord forum

  3. #3

    Default

    I am having the same problem, except that my hazards don't function. I was thinking about doing a temporary fix just like you have done with the "hot switch" but haven't jumped on that bandwagon yet.

    I have performed the EXACT same troubleshooting methods you described with about one minute of glory, then it was back the buzzing relay.

    Did you ever have any luck resolving your issue?

    Thanks.

  4. #4

    Default

    You might also have a shorted bulb. Try to remove all of the bulbs 1 by 1 & see if the signal lights works. Has any work been done before this happened?

  5. #5

    Default

    I haven't tried removing any of the bulbs although I did pull the sockets out for inspection of the wiring.

    I will try this method tonight as every other method has failed me thus far. Thanks for the tip.

  6. #6

    Default

    You are welcome. Please let me know what's the fix.

  7. #7

    Default

    My girlfriends accord had this same problem. It was irritating to say the least but I came across the problem which turned out to be the hazard button itself. I barely pushed in on the hazard button tried the blinkers and they worked. Before this the relay would buzz at first intermittently then eventually it did nothing but buzz. Replaced it with a known good relay still the same issue. Hopefully this works others out there.

  8. #8

    Default

    Quote Originally Posted by Xlr8hers View Post
    My girlfriends accord had this same problem. It was irritating to say the least but I came across the problem which turned out to be the hazard button itself. I barely pushed in on the hazard button tried the blinkers and they worked. Before this the relay would buzz at first intermittently then eventually it did nothing but buzz. Replaced it with a known good relay still the same issue. Hopefully this works others out there.
    Thanks for the heads up.

  9. #9

    Default

    i belive im having the same problem before my turn signals went completly out the started cliking on there own slow and fast sound ive checked all fuses under the dash and under the hood i dont have any idea what it could be any suggestions would greatly be appreciated. thanks

  10. #10

    Default Try the Hazard Switch

    Quote Originally Posted by lfreeman420 View Post
    i belive im having the same problem before my turn signals went completly out the started cliking on there own slow and fast sound ive checked all fuses under the dash and under the hood i dont have any idea what it could be any suggestions would greatly be appreciated. thanks
    I know this is old, but Google will pull up this post for "Accord Turn Signal Buzzing"; here's something to try: (turn signal voltage routes through Hazard switch)

    "Dirty/Corroded innards of my hazard switch made my 1994 Accord Wagon have no turn signals... took the hazard switch apart, cleaned and back together. Of course I killed the "switcher" mechanism in my Hazards; they work but I have to hold it to keep it on! I'll get a new one soon, but at least the signals work!

    (Original Symptom: right and left turn signal didn't work and the flasher relay BUZZED really loudly. Like a 1960s VW horn. I replaced the flasher relay and the new one didn't work either and made a rapid clicky noise, twice as fast as a "hyper-flash" that LED bulbs will cause. Other symptom that the bad hazard switch will give is your turn signals will trigger even without a key in the ignition: hazards are always Hot Voltage but turn signals *should* require key.)"

  11. #11

    Lightbulb

    [THANK YOU!! You saved me! They quit working three days ago and I checked the fuse and it was fine and I didnít know what to do next however, I tried the hazard button just out of pure curiosity but it didnít stay clicked in. I was like, this thing hasnít always been like this has it??? No it hasnít!! 🥳 I forgot to move my canned drink from the date the other day as I was leaving the store and it spilled all down the front of vents, hazard,& radio. Reading your post was like a lightbulb LOL sort of😁. But at least now I know what Iím looking at to fix this. Thanks again

    "Dirty/Corroded innards of my hazard switch made my 1994 Accord Wagon have no turn signals... took the hazard switch apart, cleaned and back together. Of course I killed the "switcher" mechanism in my Hazards; they work but I have to hold it to keep it on! I'll get a new one soon, but at least the signals work!

  12. #12

    Default tadalafil or cialis

    La Viagra Se Puede Comprar Sin Receta

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •