Results 1 to 11 of 11

Thread: 96 acura 2.5 tl stuck in park and....

  1. #1

    Default 96 acura 2.5 tl stuck in park and....

    I have a 96 acura 2.5 tl, The shifter is locked in park unless I use the key to unlock it. Then I have to start the car in neutral. All fuses are good, brake lights and backup lights are working. So Im thinking its the neutral safety switch ( acura calls it position sensor assy) and also the ignition switch, because it doesnt start in neutral everytime. I have to put it back in park then move it back to neutral over and over untill it will start.

    Has anyone had this problem?

    Is there a manual I can download? (chilton manual is no help)

    Where is the neutral safety switch located? Cant find it.

    Download HELMS Factory Service Manuals
    here http://www.spoonertuner.com/manuals

  2. #2

    Default

    have u tried taking the shift console apart to see if anything sticky might be causing the problem? u should also check the brake pedal switch. if it craps out, u will have this problem. the NSS is there to keep the engine from starting in gear and controls the reverse lights. usually on ford escorts when the NSS craps out, it will keep the tranny from shifting out of 1st gear.

    ur starting problem does sound like the ignition switch is goin. i have replaced this on my escort 5 times this year. i'm thinkin about riggin up a push button start now. does it mess with any of the accessories like wipers, heater, dash lights, and radio?
    fuck you and the moon!

  3. #3

    Default

    everything works perfect, brake lights and reverse lights both work. On the tl theres a backup light switch and the brake light switch, both of those are working. Thats why im thinking its the NSS or the ignition switch or both. I took everything apart inside and cant find the problem.

    Download HELMS Factory Service Manuals
    here http://www.spoonertuner.com/manuals

  4. #4

    Default

    it could be the ignition switch. u should look up what cars have the same switch and snag a couple from the junkyard. IMO, it's a good way to test it but not always will u find a working part.
    fuck you and the moon!

  5. #5

    Default

    I want to replace both, but I cant find where the neutral safety switch is located, some say its in the center console by the shifter, but looked and no where to be found, someone else said its behind the tranny inside a black covor but i cant find that either lol. Dont want to take it to a mechanic, someone out there has to know where its at on the car.

    Download HELMS Factory Service Manuals
    here http://www.spoonertuner.com/manuals

  6. #6

    Default

    i most cases the NSS is attached on the transmission with a cable from that to the shifter. it would have some wiring connected to it. since urs is a 96 i'd take it to an autoparts store that does diagnostics for free. and while ur there, pick up a repair manual. it should have the info ur looking for.
    fuck you and the moon!

  7. #7

    Default

    My problem was the neutral safety switch/gear position switch. The cost over $200 for a new one. So I went to pick n pull and got one from a Vigor just to see if it would work. And it did work. They have different part #s but the part looks exactly the same so I thought Id try it.

    Download HELMS Factory Service Manuals
    here http://www.spoonertuner.com/manuals

  8. #8

    Default

    Quote Originally Posted by DogPile View Post
    I want to replace both, but I cant find where the neutral safety switch is located, some say its in the center console by the shifter, but looked and no where to be found, someone else said its behind the tranny inside a black covor but i cant find that either lol. Dont want to take it to a mechanic, someone out there has to know where its at on the car.
    as far as i can remember our 2nd car's NSS is located on the center console. anyway i just visited this thread again because it has problems again with the NSS. i think it is not really a good idea to replace it with second hand NSS. sorry digging this up but i would just like to ask where do you get brand new acura parts? do you have any site better than ebay or amazon
    Last edited by ronierogers; 07-03-2011 at 07:20 PM.

  9. #9

    Talking need response asap!

    Quote Originally Posted by DogPile View Post
    My problem was the neutral safety switch/gear position switch. The cost over $200 for a new one. So I went to pick n pull and got one from a Vigor just to see if it would work. And it did work. They have different part #s but the part looks exactly the same so I thought Id try it.
    I know this post is 5 years+ old now, but I'm having THE SAME exact issue you were, where I have to constantly switch back & forth between neutral & park to get it to start! I see on auto zone that they look about the same, which year of the vigor's NSS did you get? was it the 94? I'm not prepared to shell out $220 for it considering the vigors is almost a 1/4th of that price & nearly identical, especially since its the holidays & need to get gifts I took the next 2 days off because my car has been leaving me stranded

  10. #10

    Default

    Not sure if it's an iPhone thing or not, but can't find 'new post' option on here. Got some pics to post and some questions to ask about the 91 prelude si that I just bought. All help appreciated!

  11. #11

    Default

    This happened to me. The brake switch was the problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •