Results 1 to 7 of 7

Thread: Turbo EG Build Question

Hybrid View

  1. #1

    Default Turbo EG Build Question

    So I have a 94 civic hatch. had a d15b in it and pieced together a turbo kit for over a yr.

    Kit consisted of:

    TD04 13g turbo (think that's the correct name; came off of first gen auto eclipse)
    CX Manifold with adaptor plate
    FMIC
    Greddy RS BOV
    P28 ECU w/ Hondata S100
    255lph fuel pump
    450cc/min injectors
    AEM Fuel Pressure Regulator
    3 in exhaust w vibrant muffler
    Replaced timing belt, valve cover gasket, and water pump

    This turbo was supposedly pushing 7 psi. I made 170whp and 150 ft lbs of torque when i got it tuned. Smashed on the car a bit and then drove about 400 miles. One night I decided to take my cousin for a spin and got on the fwy. Blew my engine as soon as I put it into 4th gear. The car kinda jerked towards the top of 3rd gear (did not redline). Ended up with rods 1 and 4 snapping.

    My original goal was to boost a stock engine without problems. I thought that a small turbo at under 10 psi with a good tune would accomplish that. Engine had less than 60k miles. Trying to figure out what went wrong and if my setup shouldve been a relatively safe one. Trying to see if it's worth it to boost another engine or sell it and stick NA.

    Thanks

  2. #2

    Default

    Rods one and four snapping on 7 psi? ORLY
    I say B/S I bet you burned up a piston from running lean and you upped the boost to show off.
    H22A,Sleeved,Ross 88mm Pistons,Eagle ESP rods,Kaizenspeed balance shaft elimination,Circuit Worx Oil Pump, Skunk2 Pro 1 cams/gears,skunk2 springs& retainers,fererrea Stainless valves, Precision 6262E, eville140 manifold,3in DP and full Vband/Exhaust,D.S.S Stage 3 axles, Royal Purple Oil"best shit in the world for H22 rocker pads" Hyundata S300 with MAC valve boost solenoid. Ching Chong WG housing with Tial internal, open Dump. Tuned by Blundar

  3. #3

    Default

    if im trying to get help how would me lying make any sense? im not here to show off, i want to understand why this possibly happened bcuz i thot i wasnt in any danger. i went to a well known tuner so i really wanna rule out running lean altho that is a possibility. another thing was that the line running from the waste gate into the downpipe was off after the thing blew. now the line was directly in the path of whatever metal flew out of my block so it might have caused the damage or been blown off because of it.

  4. #4

    Default

    Please define "line" as in the line that ran from the wastegate to the downpipe
    H22A,Sleeved,Ross 88mm Pistons,Eagle ESP rods,Kaizenspeed balance shaft elimination,Circuit Worx Oil Pump, Skunk2 Pro 1 cams/gears,skunk2 springs& retainers,fererrea Stainless valves, Precision 6262E, eville140 manifold,3in DP and full Vband/Exhaust,D.S.S Stage 3 axles, Royal Purple Oil"best shit in the world for H22 rocker pads" Hyundata S300 with MAC valve boost solenoid. Ching Chong WG housing with Tial internal, open Dump. Tuned by Blundar

  5. #5

    Default

    sorry i meant the wastegate to right before the intercooler piping. this pic should clarify what i was talking bout better than words.

    nvm cant post url's cuz i dnt have more than 15 posts. i will browse the site and post where i can then get back to here.

  6. #6

    Default

    here is the pic. i marked the line with red arrows. lighting makes it kinda hard to see but not impossible. that line was off at the end that connects to the ic piping area.

    this was right before i hooked the feed line to the turbo.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •