Results 1 to 20 of 20

Thread: civic turbo engine check light

  1. #1

    Default civic turbo engine check light

    hello, i have recently turbo'd my civic but somtimes the engine check light comes on under boost, it does not in first gear or second but somtimes 3rd gear or if im acelerating in 4th or 5th. when it comes on its starts to run poor.......... could this be down to the standard fuel pump and regulator? or is the lambda sensor to close to the turbo??? i not a clue so any help would be highly apreciated. thanks

  2. #2

    Default

    I have a Turbo CTR and im getting the same problem but i put it down to the poor octane we got here in Barbados...so i not too sure. I going get a Water Methanol Injection Kit and see if it makes a difference. It happens when my knock sensor reads over 60.

  3. #3

    Default

    it is tuned right????
    how about you read the fucking code so you know what the fuck it is

  4. #4

    Default

    Quote Originally Posted by enigma9789 View Post
    it is tuned right????
    how about you read the fucking code so you know what the fuck it is
    That would be the next best thing to do Asshole if there was a code to read. The computer never shows that something is wrong... Ask a fucking question b4 u assume...

  5. #5

    Default

    What kind of engine management system are you running? How much boost? If you increase air flow you must increase fuel into the engine. Post up more info on your build.

  6. #6

    Default

    holla y do people bitch so much on these forums i got the same prob its basically when the manifold absolute pressure sensor reads out of spec i think u gotta change the sensor to like a gm 3 bar map sensor and have it tuned ur loosing power cos it puts it into a safe mode im half way through rebuilding my engine then getting it tuned and aem ems ecu so that will be sorted

  7. #7

    Default

    Quote Originally Posted by ukturbosol View Post
    holla y do people bitch so much on these forums i got the same prob its basically when the manifold absolute pressure sensor reads out of spec i think u gotta change the sensor to like a gm 3 bar map sensor and have it tuned ur loosing power cos it puts it into a safe mode im half way through rebuilding my engine then getting it tuned and aem ems ecu so that will be sorted

    I got in an APEXI Power Commander ECU....as well i have on an APEXI A/F Guage...so the sensor on the guage could be faulty....is that what you are saying or would i need to use a different sensor altogether...???
    Last edited by Shift; 05-15-2008 at 09:10 AM.

  8. #8

    Default

    not really if u got a boost guage it will read off a seperate sensor i mean the factory map sensor it cant read over summink like 4 psi so whenever u go over that for more than a few seconds it will flick into safe mode cos ecu thinks summink is wrong hence y 1st n 2nd gear it dont occur cos u prob go through so fast ecu dont have time to register the fault get my drift ??? i recon ask a tuner to hook up an aftermarket map sensor with the apexi unit and stock ecu to work together

  9. #9

    Default

    Each time you guys are having problems like this, you have to post what type of set-up you have, especially with fuel management.....

    Most of the time, on issues like this, it is most likely a "tuning" issue or a set-up in which the MAP sensor is not upgraded or tuned for boost. Honda MAP sensors are not designed to read boost.... and when it does, it will throw a CEL with a MAP code. However, a stock Honda MAP sensor can be reconfigured to read up to 11-12 psi boost with a proper tuning device. I'm not sure if that Apexi Power Commander is capable of doing that.

  10. #10

    Default

    Quote Originally Posted by greeneg6 View Post
    Do you have a wideband O2 and a way to monitor your A/F ratio? Sounds like an overly rich condtion under boost, or like other's have said a MAP issue.

    Yeah... Its hooked up to a Greddy A/F Guage. My car is still running a bit too rich but i figured if i get water injection b4 i go on the dyno it would eliminate some of that...or am i wrong? I thought that if it was too rich it would knock less...?

  11. #11

    Default

    GReddy does not make a wideband.. last time I checked. I have a GReddy narrow band also. I can tell you now that it sucks.... that is why I also have a wideband... by AEM.

    knock is primarily due to "duration" and timing. You could be running rich on the wrong spot of your RPM. You need a re-tune.... but before that, check your compression.

  12. #12

    Default

    Ok... I going check the sensor again. My compression is good. I still running high but i got on a thick head gasket...not forged as yet.

  13. #13

    Default

    Quote Originally Posted by Shift View Post
    Yeah... Its hooked up to a Greddy A/F Guage. My car is still running a bit too rich but i figured if i get water injection b4 i go on the dyno it would eliminate some of that...or am i wrong? I thought that if it was too rich it would knock less...?
    so its not dyno tuned right???
    do you have any tuning at all?
    im thinking this is your problem

  14. #14
    Trained in the art of psi Krazed's Avatar
    Join Date
    Sep 2004
    Location
    My Boost technique is strong, you are no match!
    Posts
    10,923

    Default

    it is most likey your map pressure. ,but we can not know if you do not post your setup.

  15. #15

    Default

    Quote Originally Posted by enigma9789 View Post
    so its not dyno tuned right???
    do you have any tuning at all?
    im thinking this is your problem
    Yeah its just road tuned.

  16. #16

    Default

    so stock map sensor?? if it boost spikes over 11psi it will throw the code for map sensor..

    post your full setup.

    and i would get a dyno tune asap

  17. #17

    Default

    Quote Originally Posted by enigma9789 View Post
    so stock map sensor?? if it boost spikes over 11psi it will throw the code for map sensor..

    post your full setup.

    and i would get a dyno tune asap
    Yeah its a stock map sensor i using. i will see how soon i can get my set up...all i know is that most of my turbo and parts from a skyline. I think i got on a T51 or T56 Turbo. High Compression Pistons but a thick head gasket...so compression is around 180. Apexi Power Commander Comp. No External waste gate. Not using water injection as yet. Thats about it i could remember off the top of my head.
    Last edited by Shift; 06-19-2008 at 07:46 AM.

  18. #18

    Default

    Back when I had my ek and I built my turbo set up I had the same problem you can go to a fmu or apexi to tune your fuel curve and then intall a missing link to block off the boost pressure to the map sensor its nothing really more than a nice looking check valve with a bleed hole for vaccume thats how I got mine to go past the six pounds of boost and not throw engine codes

  19. #19

    Default

    ^ sounds like a crutch for doing it the right way.
    please dont pull up old threads

  20. #20

    Default civic turbo engine check light

    do you know of any turbo kits for 03 civic ex made by greddy......or anyone??????????

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •