PDA

View Full Version : Alternator??? HELP



smellofnitro
01-12-2011, 12:11 PM
Here is my story. I took my 96 Accord EX VTEC 4 cyl automatic to get my transmission replaced. during its visit it had the rear main seal replaced, both axles replaced and the VTEC gasket replaced. Started it and started to drive away when the battery light came on along with the SRS light and once in awhile the ABS light. The mechanic took a volt meter to the battery and it was registering almost 17. with the engine running. This wasn't happening when he was test driving it after the initial repairs or else he would have mentioned it. He did say that the alternator needed replacement cause it can overcharge the battery (which is new). I didn't have the time to leave it there so i drove it home, he said to keep the lights on and the radio on so the battery does not overcharge. While driving it home the SRS light would go off at a stop and go back on when i gave it gas, but mostly stays on. Once in a while the ABS light would go on. The battery light would stay on and sometimes go off, I turned the fan on and it would go back on, but for the most part it would stay on. also while going home i was adjusting the dash dimmer light and it would flicker all the lights on the dash.
Sorry for the rambling on, but in a nutshell if the alternator is bad can it cause these issues?? These is a great forum, i recieved alot of help and i hope I can get more help.

THANKS!

jockone
01-12-2011, 07:36 PM
In a nutshell yes it could cause the problems you are having,I would replace the alternator ASAP.

smellofnitro
01-13-2011, 09:46 AM
In a nutshell yes it could cause the problems you are having,I would replace the alternator ASAP.

In another nut shell a bad alternator can overcharge a battery?? causing the battery to get hot to the touch?